'2016/04'에 해당되는 글 18건

  1. 2016.04.30 dolphin ppa
  2. 2016.04.28 Zend OPcache must be loaded before Zend Debugger
  3. 2016.04.28 android studio ppa
  4. 2016.04.28 fcitx
  5. 2016.04.28 ardour ppa
  6. 2016.04.28 LMMS vst지원
  7. 2016.04.28 wine 1.8 ppa
  8. 2016.04.19 netis extender의 사용
  9. 2016.04.19 qtractor의 사용
  10. 2016.04.19 액세스 권한이 부족하여 utorrent를 제거할 수 없습니다.
  11. 2016.04.19 grub 부팅 순서 변경
  12. 2016.04.19 크롬 ppa 설치
  13. 2016.04.19 우분투 오라클 자바8설치
  14. 2016.04.19 안드로이드 스튜디오 Unable to run mksdcard SDK tool.
  15. 2016.04.19 우분투에서 ntfs 마운트가 제대로 안될 때
  16. 2016.04.19 you should upgrade to build-tools 21
  17. 2016.04.19 libreoffice ppa 한글 설치
  18. 2016.04.19 apt-get version확인

dolphin ppa

|
크리에이티브 커먼즈 라이선스
Creative Commons License


g++ 먼저 설치


sudo apt-add-repository ppa:ubuntu-toolchain-r/test 


sudo apt-get update


sudo apt-get install g++-4.9


sudo apt-add-repository ppa:dolphin-emu/ppa

sudo apt-get update


sudo apt-get install dolphin-emu-master



저작자 표시 비영리 변경 금지
신고

'리눅스' 카테고리의 다른 글

dolphin ppa  (0) 2016.04.30
Zend OPcache must be loaded before Zend Debugger  (0) 2016.04.28
android studio ppa  (0) 2016.04.28
fcitx  (0) 2016.04.28
ardour ppa  (0) 2016.04.28
LMMS vst지원  (0) 2016.04.28
아직 트랙백이 없음 And 아직 댓글이 없음

Zend OPcache must be loaded before Zend Debugger

|
크리에이티브 커먼즈 라이선스
Creative Commons License

이클립스 eclipse for php developer 를 설치하고

디버거를 zend debugger로 선택하면

에러가 뜬다.


일단 help-install new software에서 zend debugger를 설치하고


zend.com에서 리눅스용 zend debugger(ZendDebugger-linux-x86_64.tar.gz)파일을 다운로드하고


파일을 풀어서 나오는 dummy.php 파일은 사용하려는 사이트의 루트에 복사해주고


ZendDebugger.so파일은 /usr/lib/php/20121212 밑에 복사해주었다.


그리고


/etc/php5/apache2/php.ini 파일을 수정


================================

zend_extension=/usr/lib/php5/20121212/ZendDebugger.so


[zend_debugger]

zend_debugger.allow_hosts = 127.0.0.1

zend_debugger.expose_remotely = always

================================

를 추가해주었다.


그리고

phpinfo();

를 불러서 살펴보면 zend debugger 항목이 보인다.


그런데!


디버거만 쓰면 안되고 당연하게도 zend guard loader도 써야한다.


zend.com에서 zend-loader-php5.5-linux-x86_64.tar.gz를 다운로드 받았다.


압축을 풀어보면 

ZendGuardLoader.so 와 opcache.so 가 나온다.


그래서 이렇게 다시 php.ini파일을 수정.


; Enable Zend Debugger extension module

zend_extension=/usr/lib/php5/20121212/opcache.so

zend_extension=/usr/lib/php5/20121212/ZendGuardLoader.so

zend_extension=/usr/lib/php5/20121212/ZendDebugger.so



[zend_debugger]

zend_debugger.allow_hosts = 127.0.0.1

zend_debugger.expose_remotely = always


[zend_loader]


zend_loader.enable=1

zend_loader.disable_licensing=0

zend_loader.obfuscation_level_support=3


이렇게 해주었다.


그런데?


sudo service apache2 restart 를 해주면


에러가 난다!


왜지???


그래서 /var/log/apache2/error.log를 살펴본다.


Zend OPcache must be loaded before Zend Debugger


이렇게 나온다.


도무지 알 수가 없는데


이것을 해결하지않고 아파치가 실행이 되어도 

phpinfo();에서 보면


디버거거 DIABLED되었다고 나온다.


어디에선가 opcache가 먼저 설정된 부분이 있다.


찾아본다.


/etc/php5/apache2/conf.d 폴더로 들어가보면


05-opcache.ini -> ../../mods-available/opcache.ini


링그가 걸려있는 05-opcache.ini파일이 의심스러움

에디터로 열어서 보니 이것이 맞다.

;zend_extension=opcache.so


코멘트 처리 해주었다.

그리고 sudo service apache2 restart

그렇게 하고서 phpinfo(); 를 보니




모든 것이 제대로 설정되었다.


이클립스에서 디버거도 제대로 작동되었다.


php5의 mod enable 부분은 좀 더 깔끔하게 처리하는 방법이 있을 듯. 알아봐야할 부분.



저작자 표시 비영리 변경 금지
신고

'리눅스' 카테고리의 다른 글

dolphin ppa  (0) 2016.04.30
Zend OPcache must be loaded before Zend Debugger  (0) 2016.04.28
android studio ppa  (0) 2016.04.28
fcitx  (0) 2016.04.28
ardour ppa  (0) 2016.04.28
LMMS vst지원  (0) 2016.04.28
아직 트랙백이 없음 And 아직 댓글이 없음

android studio ppa

|
크리에이티브 커먼즈 라이선스
Creative Commons License

sudo add-apt-repository ppa:paolorotolo/android-studio

sudo apt-get update

sudo apt-get install android-studio

저작자 표시 비영리 변경 금지
신고

'리눅스' 카테고리의 다른 글

dolphin ppa  (0) 2016.04.30
Zend OPcache must be loaded before Zend Debugger  (0) 2016.04.28
android studio ppa  (0) 2016.04.28
fcitx  (0) 2016.04.28
ardour ppa  (0) 2016.04.28
LMMS vst지원  (0) 2016.04.28
아직 트랙백이 없음 And 아직 댓글이 없음

fcitx

|
크리에이티브 커먼즈 라이선스
Creative Commons License

 sudo apt-get install fcitx-hangul


저작자 표시 비영리 변경 금지
신고

'리눅스' 카테고리의 다른 글

Zend OPcache must be loaded before Zend Debugger  (0) 2016.04.28
android studio ppa  (0) 2016.04.28
fcitx  (0) 2016.04.28
ardour ppa  (0) 2016.04.28
LMMS vst지원  (0) 2016.04.28
wine 1.8 ppa  (0) 2016.04.28
아직 트랙백이 없음 And 아직 댓글이 없음

ardour ppa

|
크리에이티브 커먼즈 라이선스
Creative Commons License


http://ubuntuhandbook.org/index.php/2015/05/how-to-install-ardour-4-in-ubuntu-14-04/



sudo add-apt-repository ppa:dobey/audiotools


sudo apt-get update


sudo apt-get install ardour



저작자 표시 비영리 변경 금지
신고

'리눅스' 카테고리의 다른 글

android studio ppa  (0) 2016.04.28
fcitx  (0) 2016.04.28
ardour ppa  (0) 2016.04.28
LMMS vst지원  (0) 2016.04.28
wine 1.8 ppa  (0) 2016.04.28
qtractor의 사용  (0) 2016.04.19
아직 트랙백이 없음 And 아직 댓글이 없음

LMMS vst지원

|
크리에이티브 커먼즈 라이선스
Creative Commons License

https://lmms.io/download/#linux


http://kxstudio.linuxaudio.org/Repositories#Ubuntu


링크내용이 수시로 바뀌니 반드시 확인하고 설치할 것.


All Debian and Ubuntu users can enable our repositories by installing this deb file: kxstudio-repos.deb.

You can install it manually by running this:

# Install required dependencies if needed

sudo apt-get install apt-transport-https software-properties-common wget


# Download package file

wget https://launchpad.net/~kxstudio-debian/+archive/kxstudio/+files/kxstudio-repos_9.2.2~kxstudio1_all.deb


# Install it

sudo dpkg -i kxstudio-repos_9.2.2~kxstudio1_all.deb



sudo apt-get update

sudo apt-get install lmms

sudo apt-get install lmms-vst-full


저작자 표시 비영리 변경 금지
신고

'리눅스' 카테고리의 다른 글

fcitx  (0) 2016.04.28
ardour ppa  (0) 2016.04.28
LMMS vst지원  (0) 2016.04.28
wine 1.8 ppa  (0) 2016.04.28
qtractor의 사용  (0) 2016.04.19
grub 부팅 순서 변경  (0) 2016.04.19
아직 트랙백이 없음 And 아직 댓글이 없음

wine 1.8 ppa

|
크리에이티브 커먼즈 라이선스
Creative Commons License
sudo add-apt-repository ppa:ubuntu-wine/ppa

sudo apt-get update


sudo apt-get install wine1.8 winetricks


저작자 표시 비영리 변경 금지
신고

'리눅스' 카테고리의 다른 글

ardour ppa  (0) 2016.04.28
LMMS vst지원  (0) 2016.04.28
wine 1.8 ppa  (0) 2016.04.28
qtractor의 사용  (0) 2016.04.19
grub 부팅 순서 변경  (0) 2016.04.19
크롬 ppa 설치  (0) 2016.04.19
아직 트랙백이 없음 And 아직 댓글이 없음

netis extender의 사용

|
크리에이티브 커먼즈 라이선스
Creative Commons License

netis extender 엑스텐더

무선인터넷 사용범위 확장기라고나 할까.


설명서가 너무 부실했다.

그래서 나중에 다시 보기를 위해서 기록해놓는다.


1. netis extender의 전원을 연결한다.


2. 우선 기존 유무선 공유기(나의 경우는 오래된 모델 axler rt-tse)의 wps기능을 켜야한다.

기본 설정 값은 꺼짐 상태이기 때문에

192.168.0.1로 접속해서

무선메뉴에서 wps설정 메뉴를 선택 wps끄기의 체크를 없애고 설정변경

wps가 켜진다.

(wps기능이 없는 공유기는 netis extender를 사용할 수 없다.)


3. pbc방식-무선 장치 추가를 클릭한다.

그러면 120초 동안 무선 장치를 찾는다.

(이건 기존 유무선 공유기의 wps버튼을 3초동안 누른 것과 같은 효과라고 하는데

wps버튼을 누르는 것보다는 접속메뉴에서 선택하는 것이 더 비주얼적으로

확실하게 보이니까 더 나은 것 같다.)


4.  netis extender의 바닥에 있는 버튼 (하나 밖에 없다)을

몇초동안 눌렀다 뗀다.

아마 5초 정도는 되야되는 것 같다.


5. netis extender의 wps램프와 sys램프가 동시에 여러번 깜빡인다.

(만약에 wps램프와 sys램프가 동시에 깜빡이지않고 번갈아가면서 깜빡이면

잘못된 것이니 3번부터 다시 시도한다.)


6. 깜빡이던 것이 꺼진다. 이러면 연결되었다고 볼 수 있는데

진짜로 연결된 것인지 확인이 필요하다.


7. 연결확인을 위한 단계.

해당 컴퓨터의 네트워크 설정으로 간다.

윈도우 8의 경우 제어판-네트워크 및 공유센터에서 해당 연결 클릭(이를테면 "이더넷2")


8. 이더넷 상태 창이 뜨면 속성 클릭


9.  네트워킹 탭의 맨 아래에  TCP/ipv4를 선택 하고 속성 클릭


10. 새로 뜬 창에서 다음 ip주소 사용을 선택하고

ip주소 : 192.168.1.10

서브넷마스크 : 255.255.255.0

기본 게이트웨이 : 192.168.1.254

를 적어주고 확인


11. 웹브라우저에서 192.168.1.254로 접속한다.


12. netis extender가 제대로 작동중이면 netis설정 화면이 나올 것이고

아니면 접속할 수 없다고 나올 것이다. (제대로 안되면 1번부터 다시 시도)


13. netis설정화면에서 아래쪽의 저장을 클릭.


14. 성공했으면 다시 해당 컴퓨터의 네트워크 설정으로 간다.

윈도우 8의 경우 제어판-네트워크 및 공유센터에서 해당 연결 클릭(이를테면 "이더넷2")


15. 이더넷 상태 창이 뜨면 속성 클릭


16. 네트워킹 탭의 맨 아래에  TCP/ipv4를 선택 하고 속성 클릭


17. 자동으로 ip주소 받기를 클릭하고 확인을 클릭해준다.


18. 즐겁게 확장된 무선 인터넷을 사용한다.


저작자 표시 비영리 변경 금지
신고
아직 트랙백이 없음 And 아직 댓글이 없음

qtractor의 사용

|
크리에이티브 커먼즈 라이선스
Creative Commons License

qtractor는 좋은 프로그램으로 보였다.

audio 녹음, midi 파일 편집이 가능하다.

모든 것이 공짜다.


설치해서 사용하려고 하니 한글로 된 설명이 너무나 부족해서

막막하다.

설정에서 완전히 막힘.

삽질을 하다가 어떻게 하는 것인지 대충 발견.

잊지 않기 위해서 기록해 놓는다.


1. QjackCtrl 프로그램을 설치한다.

이것은 jack server 데몬을 제어할 수 있게 해준다.

실행하면 jack 데몬이 실행되고 창을 닫으면 데몬이 사라지므로

창을 닫으면 안된다.


2. Qsynth 프로그램을 설치한다.

Fluid R3 사운드 폰트를 설치한다.

이것은 소프트웨어 신서사이저를 사용할 수 있게 해준다.

역시 실행 후에 창을 닫으면 안된다.

setup-sound font에서 fluid r3를 선택한다.


3. 미디키보드를 연결한다.


4. Qtractor 프로그램을 설치한다.

실행하고

view-instruments 에서 /usr/share/sounds/sf2 에서

fluid r3 를 import한다.

view-windows-connections 를 선택

midi 탭 선택

왼쪽 qtractor-master를 오른쪽 fluid synth-synth input port로 연결한다.

왼쪽 midikeyboard1도 오른족 fluid synth-synth input port로 연결한다.

왼쪽 midikeyboard1을 오른쪽 qtractor-master로 연결한다.


5. 메인화면에서 오른쪽 버튼 클릭 add track해준다.

midi를 선택 omni체크 (no inst....)를 fluidR3_GM으로 바꿔준다.

뱅크는 그대로 두고 program을 적절한 악기로 선택한다.


6. 미디 키보드로 입력한다.(virtual midi keyboard를 이용해도 된다.)


끝.



저작자 표시 비영리 변경 금지
신고

'리눅스' 카테고리의 다른 글

LMMS vst지원  (0) 2016.04.28
wine 1.8 ppa  (0) 2016.04.28
qtractor의 사용  (0) 2016.04.19
grub 부팅 순서 변경  (0) 2016.04.19
크롬 ppa 설치  (0) 2016.04.19
우분투 오라클 자바8설치  (0) 2016.04.19
아직 트랙백이 없음 And 아직 댓글이 없음

액세스 권한이 부족하여 utorrent를 제거할 수 없습니다.

|
크리에이티브 커먼즈 라이선스
Creative Commons License

1. utorrent를 종료한다.


2. utorrent 사이트에서 utorrent 프로그램을 새로 다운로드 받고 설치한다.


3. 설치한 utorrent를 프로그램 제거에서 제거 클릭 후에

제거되는 도중에 설정 파일까지 제거를 체크한 다음 제거한다.


4. 다시 utorrent 프로그램을 새로 설치한다. 깨끗하게 해결된다.


저작자 표시 비영리 변경 금지
신고
아직 트랙백이 없음 And 아직 댓글이 없음

grub 부팅 순서 변경

|
크리에이티브 커먼즈 라이선스
Creative Commons License

$ sudo gedit /etc/default/grub

GRUB_DEFAULT=5

GRUB_TIMEOUT=5

$ sudo update-grub


저작자 표시 비영리 변경 금지
신고

'리눅스' 카테고리의 다른 글

wine 1.8 ppa  (0) 2016.04.28
qtractor의 사용  (0) 2016.04.19
grub 부팅 순서 변경  (0) 2016.04.19
크롬 ppa 설치  (0) 2016.04.19
우분투 오라클 자바8설치  (0) 2016.04.19
우분투에서 ntfs 마운트가 제대로 안될 때  (0) 2016.04.19
아직 트랙백이 없음 And 아직 댓글이 없음

크롬 ppa 설치

|
크리에이티브 커먼즈 라이선스
Creative Commons License

우분투소프트웨어센터에 크로미니엄이 있지만

구글크롬보다 예전 버전이다.

ppa로 최신 버전을 설치한다.



1. wget -q -O - https://dl-ssl.google.com/linux/linux_signing_key.pub | sudo apt-key add -


2. sudo sh -c 'echo "deb http://dl.google.com/linux/chrome/deb/ stable main" >> /etc/apt/sources.list.d/google-chrome.list'



3. sudo apt-get update


W: http://dl.google.com/linux/chrome/deb/dists/stable/Release 파일을 받는데 실패했습니다 Unable to find expected entry 'main/binary-i386/Packages' in Release file (Wrong sources.list entry or malformed file)

라고 나오면


sudo gedit /etc/apt/sources.list.d/google-chrome.list

명령으로


편집기를 열어서 내용을

deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main

라고 수정하고 저장.


sudo apt-get update를 다시 실행



4. sudo apt-get install google-chrome-stable


저작자 표시 비영리 변경 금지
신고

'리눅스' 카테고리의 다른 글

qtractor의 사용  (0) 2016.04.19
grub 부팅 순서 변경  (0) 2016.04.19
크롬 ppa 설치  (0) 2016.04.19
우분투 오라클 자바8설치  (0) 2016.04.19
우분투에서 ntfs 마운트가 제대로 안될 때  (0) 2016.04.19
libreoffice ppa 한글 설치  (0) 2016.04.19
아직 트랙백이 없음 And 아직 댓글이 없음

우분투 오라클 자바8설치

|
크리에이티브 커먼즈 라이선스
Creative Commons License

안드로이드 스튜디오를 사용하기 위해서는

openjdk를 쓰지않고 오라클 자바를 써야 한다.


sudo add-apt-repository ppa:webupd8team/java

sudo apt-get update

sudo apt-get install oracle-java8-installer

sudo update-alternatives --config java

sudo update-alternatives --config javac

sudo update-alternatives --config javaws


저작자 표시 비영리 변경 금지
신고

'리눅스' 카테고리의 다른 글

grub 부팅 순서 변경  (0) 2016.04.19
크롬 ppa 설치  (0) 2016.04.19
우분투 오라클 자바8설치  (0) 2016.04.19
우분투에서 ntfs 마운트가 제대로 안될 때  (0) 2016.04.19
libreoffice ppa 한글 설치  (0) 2016.04.19
apt-get version확인  (0) 2016.04.19
아직 트랙백이 없음 And 아직 댓글이 없음

안드로이드 스튜디오 Unable to run mksdcard SDK tool.

|
크리에이티브 커먼즈 라이선스
Creative Commons License

Unable to run mksdcard SDK tool.


sudo apt-get install lib32z1 lib32ncurses5 lib32bz2-1.0 lib32stdc++6

실행 후에 다시 안드로이드 스튜디오 실행


저작자 표시 비영리 변경 금지
신고
아직 트랙백이 없음 And 아직 댓글이 없음

우분투에서 ntfs 마운트가 제대로 안될 때

|
크리에이티브 커먼즈 라이선스
Creative Commons License

윈도우에서 fast boot등으로 시스템을 사용하면

우분투에서 nfts가 제대로 마운트가 안되고

리드온리로 마운트하라는 말이 나온다.


윈도우에서 명령창에서 다음과 같이 하면

다음 부팅시에 우분투에서 제대로 마운트가 된다


shutdown /s /t 0


아예 윈도우에 위 내용으로 batch파일을 만들어놓고 사용하면 더 편한다.


저작자 표시 비영리 변경 금지
신고

'리눅스' 카테고리의 다른 글

grub 부팅 순서 변경  (0) 2016.04.19
크롬 ppa 설치  (0) 2016.04.19
우분투 오라클 자바8설치  (0) 2016.04.19
우분투에서 ntfs 마운트가 제대로 안될 때  (0) 2016.04.19
libreoffice ppa 한글 설치  (0) 2016.04.19
apt-get version확인  (0) 2016.04.19
아직 트랙백이 없음 And 아직 댓글이 없음

you should upgrade to build-tools 21

|
크리에이티브 커먼즈 라이선스
Creative Commons License

안드로이드 스튜디오에서

Warning:Project is building density based multiple APKs but using tools version 19, you should upgrade to build-tools 21 or above to ensure proper packaging of resources.


tools-android-sdk manager

android sdk-sdk tools에서

show package detail체크

sdk build tool 버전 21.x.x 선택-설치



프로젝트에서 오른쪽 마우스 클릭

open module settings

build tools version을 21로 선택


project-rebuild project


저작자 표시 비영리 변경 금지
신고
아직 트랙백이 없음 And 아직 댓글이 없음

libreoffice ppa 한글 설치

|
크리에이티브 커먼즈 라이선스
Creative Commons License

우분투 소프트웨어센터에서 설치하면

과거의 버전이 설치된다.

최신의 버전을 설치하려면 ppa방식으로 설치하면 된다.


$ sudo add-apt-repository ppa:libreoffice/ppa

$ sudo apt-get update

$ sudo apt-get install libreoffice

$ sudo apt-get install libreoffice-l10n-ko


저작자 표시 비영리 변경 금지
신고

'리눅스' 카테고리의 다른 글

grub 부팅 순서 변경  (0) 2016.04.19
크롬 ppa 설치  (0) 2016.04.19
우분투 오라클 자바8설치  (0) 2016.04.19
우분투에서 ntfs 마운트가 제대로 안될 때  (0) 2016.04.19
libreoffice ppa 한글 설치  (0) 2016.04.19
apt-get version확인  (0) 2016.04.19
아직 트랙백이 없음 And 아직 댓글이 없음

apt-get version확인

|
크리에이티브 커먼즈 라이선스
Creative Commons License

apt-show-versions <package>

저작자 표시 비영리 변경 금지
신고

'리눅스' 카테고리의 다른 글

grub 부팅 순서 변경  (0) 2016.04.19
크롬 ppa 설치  (0) 2016.04.19
우분투 오라클 자바8설치  (0) 2016.04.19
우분투에서 ntfs 마운트가 제대로 안될 때  (0) 2016.04.19
libreoffice ppa 한글 설치  (0) 2016.04.19
apt-get version확인  (0) 2016.04.19
아직 트랙백이 없음 And 아직 댓글이 없음
prev | 1 | next

티스토리 툴바